所有推荐版本均基于每个系列的最新发行版本。

支持软件的要求

Joomla的要求!3.x

软件受到推崇的最低限度更多信息
PHP [1] 7.3 + 5.3.10 (Magic Quotes GPC,MB字符串重载=关闭)
(Zlib压缩支持,XML支持,INI解析器支持,JSON支持,MB语言=默认)
支持的数据库
MySQL [2] 5.5.3 + 5.1 (需要InnoDB支持)
SQL服务器 10.50.1600.1 + 10.50.1600.1 https://www.microsoft.com/sql
PostgreSQL的 9.1 + 8.3.18 https://www.postgresql.org/
支持的Web服务器
阿帕奇[3] 2.4以上 2.0 (使用mod_mysql,mod_xml和mod_zlib)
Nginx的 1.8 + 1.0 https://www.nginx.com/resources/wiki/
Microsoft IIS [6] 7 7 https://www.iis.net
请参阅https://docs.joomla.org/Joomla_Browser_Support,以获取Joomla 3.x支持的浏览器列表。

不支持软件的要求

Joomla的要求!4.x

此版本的Joomla尚未发布,因此应将这些版本视为初步版本
软件受到推崇的最低[7]更多信息
的PHP 7.4 7.2.5 https://www.php.net
支持的数据库
的MySQL 5.6 + 5.6 https://www.mysql.com
PostgreSQL的 11.0 + 11.0 (PHP中的ext / pgsql支持已删除。现在使用PostgreSQL PDO驱动程序)
支持的Web服务器
阿帕奇[3] 2.4以上 2.4 (使用mod_mysql,mod_xml和mod_zlib)
Nginx的 1.18 + 1.10 https://www.nginx.com/resources/wiki/
Microsoft IIS [6] 10 + 8 https://www.iis.net

Joomla的要求!1.6、1.7和2.5

支持此版本的Joomla!截至2014年12月31日
软件受到推崇的最低限度更多信息
的PHP 5.6 5.2.4 https://www.php.net
支持的数据库
的MySQL 5.0.4 + 5.0.4 https://www.mysql.com
SQL Server [5] 10.50.1600.1 + 10.50.1600.1 https://www.microsoft.com/sql
支持的Web服务器
阿帕奇[3] 2.2 + 2.0 (使用mod_mysql,mod_xml和mod_zlib)
Nginx的 1.1 + 1.0 https://www.nginx.com/resources/wiki/
Microsoft IIS [6] 7 7 https://www.iis.net

Joomla的要求!1.5

支持此版本的Joomla!截至2012年12月31日
软件受到推崇的最低限度更多信息
PHP [4] 5.3 4.3.10 https://www.php.net
支持的数据库
的MySQL 4.1.x以上 3.23 https://www.mysql.com
支持的Web服务器
阿帕奇[3] 2.0以上 1.3 (使用mod_mysql,mod_xml和mod_zlib)
Microsoft IIS [6] 7 6 https://www.iis.net

Joomla的要求!1.0

支持此版本的Joomla!于2009年7月22日结束
软件受到推崇的最低限度更多信息
PHP [4] 5.3 4.3.10 https://www.php.net
支持的数据库
的MySQL 4.1.x以上 3.23 https://www.mysql.com
支持的Web服务器
阿帕奇[3] 2.0以上 1.3 (使用mod_mysql,mod_xml和mod_zlib)
Microsoft IIS [6] 7 6 https://www.iis.net

脚注

[1] 3.0到3.2版本需要PHP 5.3.1。在3.3,最低要求提高到PHP 5.3.10。Joomla!版本3.5及更高版本与PHP 7兼容。

[2]从Joomla开始!3.5,默认情况下,支持MySQL的`utf8mb4`字符集已添加并由支持该字符集的服务器使用。

[3]为了使用SEO URL,您将需要安装Apache mod_rewrite扩展。

[4]不要使用PHP 4.3.9、4.4.2或5.0.4。这些版本具有已知的错误,会干扰安装。用于PHP 4.4的Zend Optimizer 2.5.10也存在严重的错误,您应该要求主机升级到较新的版本。Joomla!1.5.15和更高版本与PHP 5.3兼容。请注意,OpenID库与PHP 5.3不兼容。

[5]在2.5版本中增加了对Microsoft SQL Server的支持。1.6和1.7没有此支持。

[6]对于Microsoft IIS(取决于您的设置),您可能需要以下内容:

有关使用Microsoft IIS的更多帮助,请访问Joomla!IIS论坛

[7]这是保证可以正常工作的最低版本,较旧的版本可能有效,但不受支持。

配置选项

如果在本地计算机上安装,则有许多软件包可以帮助您比单独安装更快地进行设置:

  • LAMP(Linux)-大多数Linux发行版都带有预配置的LAMP服务器。
  • WAMP(Windows)-有关更多信息,请访问WampServer主页
  • MAMP(Apple OS)-有关更多信息,请访问MAMP主页
  • XAMPP(多平台)-不适用于实时站点。有关更多信息,请访问XAMPP主页。

如果您需要其他选择,我们建议访问我们的安装论坛以获取更多信息或查看我们的可选技术要求列表