所有推荐版本均基于每个系列的最新发行版本。

支持软件的要求

Joomla的要求!3.x

软件受到推崇的最低限度更多信息
PHP [1] 7.3 + 5.3.10 (Magic Quotes GPC,MB字符串重载=关闭)
(Zlib压缩支持,XML支持,INI解析器支持,JSON支持,MB语言=默认)
支持的数据库
MySQL [2] 5.5.3 + 5.1 (需要InnoDB支持)
SQL服务器 10.50.1600.1 + 10.50.1600.1 https://www.microsoft.com/sql
PostgreSQL的 9.1 + 8.3.18 https://www.postgresql.org/
支持的Web服务器
阿帕奇[3] 2.4以上 2.0 (使用mod_mysql,mod_xml和mod_zlib)
Nginx的 1.8 + 1.0 https://www.nginx.com/resources/wiki/
Microsoft IIS [6] 7 7 https://www.iis.net
请参阅https://docs.joomla.org/Joomla_Browser_Support,以获取Joomla 3.x支持的浏览器列表。

不支持软件的要求

Joomla的要求!4.x

此版本的Joomla尚未发布,因此应将这些版本视为初步版本
软件受到推崇的最低[7]更多信息
的PHP 7.4 7.2.5 https://www.php.net
支持的数据库
的MySQL 5.6 + 5.6 https://www.mysql.com
PostgreSQL的 11.0 + 11.0 (PHP中的ext / pgsql支持已删除。现在使用PostgreSQL PDO驱动程序)
支持的Web服务器
阿帕奇[3] 2.4以上 2.4 (使用mod_mysql,mod_xml和mod_zlib)
Nginx的 1.18 + 1.10 https://www.nginx.com/resources/wiki/
Microsoft IIS [6] 10 + 8 https://www.iis.net

Joomla的要求!1.6、1.7和2.5

支持此版本的Joomla!截至2014年12月31日
软件受到推崇的最低限度更多信息
的PHP 5.6 5.2.4 https://www.php.net
支持的数据库
的MySQL 5.0.4 + 5.0.4 https://www.mysql.com
SQL Server [5] 10.50.1600.1 + 10.50.1600.1 https://www.microsoft.com/sql
支持的Web服务器
阿帕奇[3] 2.2 + 2.0 (使用mod_mysql,mod_xml和mod_zlib)
Nginx的 1.1 + 1.0 https://www.nginx.com/resources/wiki/
Microsoft IIS [6] 7 7 https://www.iis.net

Joomla的要求!1.5

支持此版本的Joomla!截至2012年12月31日
软件受到推崇的最低限度更多信息
PHP [4] 5.3 4.3.10 https://www.php.net
支持的数据库
的MySQL 4.1.x以上 3.23 https://www.mysql.com
支持的Web服务器
阿帕奇[3] 2.0以上 1.3 (使用mod_mysql,mod_xml和mod_zlib)
Microsoft IIS [6] 7 6 https://www.iis.net

Joomla的要求!1.0

支持此版本的Joomla!于2009年7月22日结束
软件受到推崇的最低限度更多信息
PHP [4] 5.3 4.3.10 https://www.php.net
支持的数据库
的MySQL 4.1.x以上 3.23 https://www.mysql.com
支持的Web服务器
阿帕奇[3] 2.0以上 1.3 (使用mod_mysql,mod_xml和mod_zlib)
Microsoft IIS [6] 7 6 https://www.iis.net

脚注

[1] 3.0到3.2版本需要PHP 5.3.1。在3.3,最低要求提高到PHP 5.3.10。Joomla!版本3.5及更高版本与PHP 7兼容。

[2]从Joomla开始!3.5,默认情况下,支持MySQL的`utf8mb4`字符集已添加并由支持该字符集的服务器使用。

[3]为了使用SEO URL,您将需要安装Apache mod_rewrite扩展。

[4]不要使用PHP 4.3.9、4.4.2或5.0.4。这些版本具有已知的错误,会干扰安装。用于PHP 4.4的Zend Optimizer 2.5.10也存在严重的错误,您应该要求主机升级到较新的版本。Joomla!1.5.15和更高版本与PHP 5.3兼容。请注意,OpenID库与PHP 5.3不兼容。

[5]在2.5版本中增加了对Microsoft SQL Server的支持。1.6和1.7没有此支持。

[6]对于Microsoft IIS(取决于您的设置),您可能需要以下内容:

有关使用Microsoft IIS的更多帮助,请访问Joomla!IIS论坛

[7]这是保证可以正常工作的最低版本,较旧的版本可能有效,但不受支持。

配置选项

如果在本地计算机上安装,则有许多软件包可以帮助您比单独安装更快地进行设置:

  • LAMP(Linux)-大多数Linux发行版都带有预配置的LAMP服务器。
  • WAMP(Windows)-有关更多信息,请访问WampServer主页
  • MAMP(Apple OS)-有关更多信息,请访问MAMP主页
  • XAMPP(多平台)-不适用于实时站点。有关更多信息,请访问XAMPP主页。

如果您需要其他选择,我们建议访问我们的安装论坛以获取更多信息或查看我们的可选技术要求列表

所有推荐版本均基于每个系列的最新发行版本。

支持软件的要求

Joomla的要求!3.x

软件受到推崇的最低限度更多信息
PHP [1] 7.3 + 5.3.10 (Magic Quotes GPC,MB字符串重载=关闭)
(Zlib压缩支持,XML支持,INI解析器支持,JSON支持,MB语言=默认)
支持的数据库
MySQL [2] 5.5.3 + 5.1 (需要InnoDB支持)
SQL服务器 10.50.1600.1 + 10.50.1600.1 https://www.microsoft.com/sql
PostgreSQL的 9.1 + 8.3.18 https://www.postgresql.org/
支持的Web服务器
阿帕奇[3] 2.4以上 2.0 (使用mod_mysql,mod_xml和mod_zlib)
Nginx的 1.8 + 1.0 https://www.nginx.com/resources/wiki/
Microsoft IIS [6] 7 7 https://www.iis.net
请参阅https://docs.joomla.org/Joomla_Browser_Support,以获取Joomla 3.x支持的浏览器列表。

不支持软件的要求

Joomla的要求!4.x

此版本的Joomla尚未发布,因此应将这些版本视为初步版本
软件受到推崇的最低[7]更多信息
的PHP 7.4 7.2.5 https://www.php.net
支持的数据库
的MySQL 5.6 + 5.6 https://www.mysql.com
PostgreSQL的 11.0 + 11.0 (PHP中的ext / pgsql支持已删除。现在使用PostgreSQL PDO驱动程序)
支持的Web服务器
阿帕奇[3] 2.4以上 2.4 (使用mod_mysql,mod_xml和mod_zlib)
Nginx的 1.18 + 1.10 https://www.nginx.com/resources/wiki/
Microsoft IIS [6] 10 + 8 https://www.iis.net

Joomla的要求!1.6、1.7和2.5

支持此版本的Joomla!截至2014年12月31日
软件受到推崇的最低限度更多信息
的PHP 5.6 5.2.4 https://www.php.net
支持的数据库
的MySQL 5.0.4 + 5.0.4 https://www.mysql.com
SQL Server [5] 10.50.1600.1 + 10.50.1600.1 https://www.microsoft.com/sql
支持的Web服务器
阿帕奇[3] 2.2 + 2.0 (使用mod_mysql,mod_xml和mod_zlib)
Nginx的 1.1 + 1.0 https://www.nginx.com/resources/wiki/
Microsoft IIS [6] 7 7 https://www.iis.net

Joomla的要求!1.5

支持此版本的Joomla!截至2012年12月31日
软件受到推崇的最低限度更多信息
PHP [4] 5.3 4.3.10 https://www.php.net
支持的数据库
的MySQL 4.1.x以上 3.23 https://www.mysql.com
支持的Web服务器
阿帕奇[3] 2.0以上 1.3 (使用mod_mysql,mod_xml和mod_zlib)
Microsoft IIS [6] 7 6 https://www.iis.net

Joomla的要求!1.0

支持此版本的Joomla!于2009年7月22日结束
软件受到推崇的最低限度更多信息
PHP [4] 5.3 4.3.10 https://www.php.net
支持的数据库
的MySQL 4.1.x以上 3.23 https://www.mysql.com
支持的Web服务器
阿帕奇[3] 2.0以上 1.3 (使用mod_mysql,mod_xml和mod_zlib)
Microsoft IIS [6] 7 6 https://www.iis.net

脚注

[1] 3.0到3.2版本需要PHP 5.3.1。在3.3,最低要求提高到PHP 5.3.10。Joomla!版本3.5及更高版本与PHP 7兼容。

[2]从Joomla开始!3.5,默认情况下,支持MySQL的`utf8mb4`字符集已添加并由支持该字符集的服务器使用。

[3]为了使用SEO URL,您将需要安装Apache mod_rewrite扩展。

[4]不要使用PHP 4.3.9、4.4.2或5.0.4。这些版本具有已知的错误,会干扰安装。用于PHP 4.4的Zend Optimizer 2.5.10也存在严重的错误,您应该要求主机升级到较新的版本。Joomla!1.5.15和更高版本与PHP 5.3兼容。请注意,OpenID库与PHP 5.3不兼容。

[5]在2.5版本中增加了对Microsoft SQL Server的支持。1.6和1.7没有此支持。

[6]对于Microsoft IIS(取决于您的设置),您可能需要以下内容:

有关使用Microsoft IIS的更多帮助,请访问Joomla!IIS论坛

[7]这是保证可以正常工作的最低版本,较旧的版本可能有效,但不受支持。

配置选项

如果在本地计算机上安装,则有许多软件包可以帮助您比单独安装更快地进行设置:

  • LAMP(Linux)-大多数Linux发行版都带有预配置的LAMP服务器。
  • WAMP(Windows)-有关更多信息,请访问WampServer主页
  • MAMP(Apple OS)-有关更多信息,请访问MAMP主页
  • XAMPP(多平台)-不适用于实时站点。有关更多信息,请访问XAMPP主页。

如果您需要其他选择,我们建议访问我们的安装论坛以获取更多信息或查看我们的可选技术要求列表

Joomla 4.0.0 Beta 7 - Ready for a new world of possibilities. Use the hashtag #joomla4beta

Once again the Joomla Project is pleased to announce the availability of the Joomla 4.0 Beta 7 release, and Joomla 3.10 Alpha 5.

We expect this to be the last beta of Joomla 4 and to have a Release Candidate available in March. We will also make a new portal available for translation teams to submit Joomla 4 language packs to coincide with the first Release Candidate.

We invite you to download, install and test the package to improve quality assurance for the forthcoming 4.0 release and to discover the new features introduced in this major release.

Do you want to try Joomla 4.0 Beta without migrating one of your sites? Test it directly at launch.joomla.org

What is the difference between Beta 6 and Beta 7?

Joomla 4 Beta 7 contains:

  • An upgrade from Bootstrap 4 to Bootstrap 5 in response to the community initiated discussions on GitHub.

We invite you to test this version and will be very grateful to receive all feedback you can provide, in addition to reporting issues and bugs in the Joomla CMS Issue Tracker.

In order to update from Joomla 4.x to any newer release please make sure you configure your Joomla Update Components Options to point to the Update Channel “Testing” and set the Minimum Stability to “Beta” this setting also now supports updates between pre-releases.

For a complete list of known backward compatibility issues for version 4.0, please see Potential backward compatibility issues in Joomla 4.0 in the documentation site.

 

Download Joomla 4 Beta 7
English (UK), 4.0.0 Beta 7 Full Package.

Please visit GitHub to see all changes applied between Beta 6 and Beta 7.

Joomla 3.10 helps with the transition to Joomla 4

Along with Joomla 4 Beta 7, we are releasing the fifth alpha version of Joomla 3.10.

Joomla 3.10 is the bridge between the 2 major series. Joomla 3.10 stable will primarily be a release containing backports of API changes from the Joomla 4.0 development branch to help ease the transition to the next major release for the community. Joomla 3.10 will be supported for 2 years after it has been finally released.

With Joomla 3.10 we introduce a new feature to the Joomla Update component to help you with your mini-migration process: the Pre-Update Checker.

Once your website is updated to 3.10, the pre-update checker will allow you to check the compatibility with the Joomla 4.0 minimum requirements in terms of the current hosting environment and, more importantly, your installed extensions. This will help you migrate to Joomla 4.0 smoothly.

Call for Extension and Templates Developers Feedback!

We especially want to extend this call to test and more importantly feedback to all Joomla extension and template developers. Your products contribute to one of Joomla’s key features: its extensibility. This release is the perfect moment to start working on getting extensions and templates ready for the stable version of Joomla 4.0 and 3.10. Your feedback is very crucial for the upcoming releases.

You can help us a lot by opening a PR or Issue on GitHub or getting in touch with George Wilson (该邮件地址已受到反垃圾邮件插件保护。要显示它需要在浏览器中启用 JavaScript。) and Tobias Zulauf (该邮件地址已受到反垃圾邮件插件保护。要显示它需要在浏览器中启用 JavaScript。) on these topics, so we can make sure that all the points have been reviewed upfront.

Can I update my website from 3.9.x to Joomla 4 Beta 7?

The simple answer here is yes. Not on a production site of course, but if you want to test the update to Joomla 4, now you can.

Upgrade notice: Due to merging both a preparatory step for an upcoming Joomla 4.1 feature and adding back the custom_data property - there will be issues upgrading from beta 3 to beta 4 (or later). You’ll need to run a small amount of SQL before you make the upgrade - this is on the following documentation page: https://docs.joomla.org/J4.x:Upgrade_to_4.0_Beta_4

In order to upgrade from 3.9.x to Joomla 4, you have to go via the latest 3.10 alpha at this point. There is no direct upgrade path between 3.9 and 4.x planned nor supported. All upgrades go via 3.10.

For the upgrade please follow these steps:

  1. Go to the Joomla Update Component Options and switch the Update Channel to “Testing” and the Minimum Stability option to “Alpha”.
  2. Update to the latest 3.10 alpha using the Joomla Update Component.
  3. Now please switch the Update Channel to “Custom URL” and set the Custom URL to “https://update.joomla.org/core/test/310to4_list.xml”
  4. Now you get the update to the latest 4.0 beta release.
  5. Please carefully check the results you get from the pre-update checker in terms of your environment and specify your installed extensions before upgrading.
  6. After the upgrade please switch back to the “Testing” Update Channel with the “Beta” minimum stability to get future updates between Joomla 4 betas.

Do you need more details on the upgrade process? You’ll find them in the documentation.

When is the stable release due?

The timeline for the stable release depends on the feedback we get from developers and users. Join us in testing and reporting to help ensure a solid, timely delivery. Do you want to help out? Great! Below you’ll find more information about what you can do.

The most up-to-date information regarding this timeline can be found in our project roadmap.

Where can I find documentation about Joomla 4?

We have started to provide some tutorials to help you with Joomla 4. We’ll be writing more tutorials to help you understand the significant changes in Joomla 4. You can find the existing ones, like how to create a Plugin or a Module for Joomla 4, namespaces conventions, prepared statements, using the new web asset classes and many more here.

We encourage developers to help in writing the documentation about Joomla 4 on docs.joomla.org to support and guide users as well as other extension developers.

A JDocs page will help developers to see the existing documentation and the documentation that still needs to be written.

We invite you to check it regularly, update it and provide the missing content: https://docs.joomla.org/JDOC:Joomla_4_Tutorials_Project

How can I help Joomla 4 development?

To help ensure the 4.0 release and our major features are “production-ready”, we need you! Test the releases and report any bugs you may find at issues.joomla.org.

To make the life of testers (and early adopters) easier, updating is possible from the Beta version to the next Beta, RC or stable version (we will remain strict in updating the deleted files and modifying the SQL changes).

As previously stated, we’re focusing on Joomla 4 to get it released as soon as possible. Therefore, we do not plan to release more 3.x minor versions, except for 3.10.

All feature proposals should be directed toward the 4.1 release.

A huge Thank You to our volunteers!

This Beta and Alpha release is the result of thousands of hours of work by dozens of volunteers.

A big thank you goes out to everyone who has contributed to the 4.0 Beta and the 3.10 Alpha release.

Translations

使用Joomla开始和发展您的业务!

的Joomla!是世界上最流行的软件包之一。它用于为全球的小型企业,政府,非营利组织和大型组织构建,组织,管理和发布内容。Joomla得到了大型生态系统和权力的支持:

  • 近2百万活跃网站
  • 超过9%的已知商业网站
  • 超过6%的CMS全球市场
  • 超过整个网络的3%!

Joomla提供了一个发展业务构建网站和应用程序的绝佳机会。坚如磐石的代码库和庞大的全球社区将帮助您快速上手。无论您是要构建网站还是开发应用程序,开发模板或扩展或基于我们框架的全新内容,使用Joomla,可能性无穷无尽,立即开始使用Joomla!

Joomla的好处

Joomla的7个理由!是您在线项目的完美平台。

  • Joomla有数千个经过验证的第三方扩展,可以在Joomla扩展目录 - extensions.joomla.org上轻松找到
  • 还有数以千计的高质量模板,其中很多都是免费的。付费模板也可用,并提供世界一流的支持。许多模板提供了图形用户界面(GUI),允许您更改颜色,字体,布局和功能,而无需触及任何代码行!
  • 布局和覆盖系统以及内置的可扩展功能使您可以轻松创建自定义解决方案,包括:
    • 自定义布局
    • 语言覆盖
    • 模板覆盖
    • 自定义CSS
    • ... 以及更多。
  • 丰富的免费文档和视频培训使学习Joomla变得轻而易举,确保访问:
  • Joomla拥有强大的SEO工具,开箱即用 
    • 元数据和关键字
    • Mod_rewrite支持SEF URL
    • 创建菜单时考虑到创建清晰一致的站点地图
      • 每次创建文章或菜单项时,它都会自动为其默认PHP字符串创建别名,以便指向特定页面的链接既是用户又是搜索引擎友好的。
      • 每个菜单项都可以有自己的元描述,关键字和机器人设置,允许您自定义内容的SEO设置,以提供最佳的可用性和可搜索性。这些功能使您可以使您的内容中最重要的部分在其他类似的网站中闪耀,为您提供技术优势。
  • Joomla由一个独特的志愿者社区创建,维护和支持,他们相信每个人都应该免费提供。
  • Joomla还包括广泛的扩展开发人员,设计人员,集成商,撰稿人,支持人员,系统/服务器管理员,来自各行各业的人们,他们热衷于Free Forever开源解决方案。
  • 您可以从世界各地的程序员那里免费获得数千小时的开发时间和专业知识。免费和开源也意味着如果您需要更改网站管理员,可以使用其他许多网站管理员,而无需重建您的网站!

凭借设计强大的代码库,Joomla还具有内置的双因素身份验证和开箱即用的广泛访问控制级别。Joomla专注的安全打击团队始终致力于领先于其他人,并且在利用漏洞之前就已经广为人知。

多语言变得容易。凭借70多个可用于核心的翻译包和开箱即用的多语言内容管理语言关联支持,使用Joomla创建多语言网站是一个简单而直接的过程。

Joomla稳定的核心和可扩展性使您的网站或应用程序能够跟上您的业务从一个萌芽的想法展开到一个完全成熟的财富500强。扩展和添加新功能,快速周转,没有头痛。
如果您需要一个适应复杂需求的良好平台,Joomla就是CMS。使用集成ACL(访问控制列表),您可以为不同类型的用户定义粒度访问权限。借助翻译包,您的网站可以多语言开箱即用。通过记录的API强大的代码库,您可以生成高质量的解决方案,并且可以在未来延续。通过现代技术和最低要求,如PHP 7.x(从Joomla 4开始需要),您可以期待稳定的开发环境。通过Overrides,可以轻松地操作输出而无需核心黑客,这意味着您的更新将顺利进行。

Joomla不仅是一个CMS,而且是一个稳定轻量级的PHP框架,允许您使用PHP编写Web和命令行应用程序。Joomla框架易于根据您的需求进行调整和扩展。CMS和框架是相互独立的,无需安装CMS即可使用该框架!使用Joomla Framework可以实现的一个很好的例子是我们的问题跟踪器

Joomla的核心功能

这里有一些Joomla!你会爱的功能。

  • 多语言:提供70多种语言。
  • 搜索引擎优化:开箱即用的SEO和SEF。
  • 灵活:建立博客,商业网站,内联网,社区网站......从最简单到最复杂的网站。
  • 永远自由:Joomla!可以在GPL下免费使用。
  • 可扩展:超过8,000个扩展可用于扩展您的网站并扩展其功能。
  • 用户管理(ACL):ACL代表访问控制列表,它允许您管理站点的用户和不同的组。
  • 菜单管理:根据需要创建任意数量的菜单和菜单项。
  • 缓存管理:通过缓存加速您的网站。
  • 模板覆盖:实现卓越的定制设计。
  • Jlayouts:允许您从对象/数据数组中呈现HTML。
  • 模板分配:将特定模板分配给特定页面。
  • 响应:Joomla!使用Bootstrap实现完美的响应式设计。
  • 用Less做更多:Joomla!功能少的CSS。
  • 模板框架:使用外部模板框架或模板俱乐部。
  • 创建自己的:您可以创建自己的模板。你的想象力是唯一的限制。
  • 发布工具:选择发布文章的时间。
  • WYSIWYG编辑器:编辑内容,不需要任何代码知识。
  • 内容版本控制:您永远不会再丢失以前重要版本的文章以及您网站上的其他更改。
  • 文章管理:添加,管理和组织您的文章。
  • 前端编辑:在浏览您的站点时编辑您的内容。
  • 编辑器按钮:只需单击一下,即可为内容添加额外功能。
  • 拖放图像:添加图像就像将图像从计算机直接拖放到内容中一样简单。这适用于您使用默认TinyMCE WYSIWYG编辑器的任何地方。
  • 媒体经理:上传和维护图像和其他文件的工具。
  • 类别:能够创建具有嵌套的类别,并且不限制深度。
  • 重定向:在需要时轻松重定向URL。
  • 横幅:通过添加横幅或广告来实现您的网站货币化。
  • 联系人:添加多个联系人,部门和联系表格
  • 标签:当分类不足以构建您的内容时。
  • 联合:从您的内容创建RSS源。
  • 新闻Feed:在您的网站上显示外部新闻Feed。
  • 自定义字段:15种不同的字段类型,可添加到文章,用户和联系人。
  • 搜索:访客将能够快速,轻松地找到适当的信息。
  • 消息:在管理员之间发送消息。

无论您的项目是什么,从简单的展示到复杂的项目,
Joomla都是您在网络上取得成功的正确解决方案!现在就试试!

下载JOOMLA